HSPポータル
サイトマップ お問い合わせ


HSPTV!掲示板


未解決 解決 停止 削除要請

2014
0728
下郎HSP3Dish 別機種による不具合5解決


下郎

リンク

2014/7/28(Mon) 15:21:44|NO.63152

HSP3Dishにてandroid用アプリを制作しております。

アプリ自体は遊べるようになり、グラフィックを少々追加や差し替えを行っている状態
なのですが、計3つの機種にインストールをして実機起動を試しています。
しかし、そのうちの1つがどうも上手く起動してくれません。
使っている機種は

スマートフォン
ls115
F-07E

タブレットPC
ASUS TF101

以上です。
そのうち、不具合が生じるのがls115です。
他二つは正常に起動します。

不具合の内容としては
・差し替えたはずの画像が差し替える前になっている。(差し替えられているものもある)
・強制的に選択肢とは別のルートでストーリーが進む

などです。
そもそも差し替え前の画像データを含まずにビルドしているので
差し替え前の画像が表示されること自体おかしいのですが……。

スクリプトも一から確認してみましたがどこもおかしいところはありませんでした。

機種によって不具合が生じたりするものなのでしょうか?

現在、不具合が生じている機種は最近調子が悪いのでそのためかもしれませんが
入っていない画像データを読み込んでいるのが気になったので
質問させていただきました。
よろしければご回答よろしくお願いします。



この記事に返信する


kanahiron

リンク

2014/7/28(Mon) 15:29:36|NO.63153

一度アンインストールして再インストールや端末の再起動をしてもダメでしょうか

それとls115(LS115)ではなくIS11S(あいえす11えす)じゃないでしょうか?
もしIS11SならRAMが512MBしかない旧世代ですのでOSのキャッシュとして画像が残ってしまっているのかもしれません
それならアンインストールで消えると思います



下郎

リンク

2014/7/29(Tue) 02:16:26|NO.63168

ご回答ありがとうございます。
一度、アンインストールをして再度インストールも実行済みでしたが
それでも不具合が発生してしまいます。
やはり機種の問題というより、実機そのものの不具合なのでしょうか。



kanahiron

リンク

2014/7/29(Tue) 13:59:26|NO.63181

もしかしたらAndroid APIのレベルが高いのかもしれません
現在のHSPDishではデフォルトのAPI Levelが17になっています(4.2 JB)
対してls115(IS11S?)ではAndroid 2.3、API Level 9です
アプリは作られたAPI Levelより端末のAPIが低いと動作しません(あるいはおかしな動作)
アプリには動作に必要な最低限のAPI Levelを記述することになっていますが、書かなくてもいいということになっている
もしHSPDishで作成されるアプリに最低限のAPI Levelが書いてないなら、動作しない端末でもインストールする事ができてしまいます

ちなみに昔はAndroid 2.3.3を指定してね、と書いてあった気がします(API Level 10)
もしかしたらアップデートで必要API Levelが上がり、昔の端末では動かないのが仕様かもしれません
DishのC++のソース読める方かおにたまさんしかわからないですねこれは…



下郎

リンク

2014/7/31(Thu) 03:29:12|NO.63219

ご回答ありがとうございます。
返信遅れて申し訳ありません。

そういうことでしたか。
なら仕方がないというか解決しようがない問題ですね。
実機による起動テストができないわけではありませんので
これでこの質問は終了とさせていただきます。
kanahiron様、ご丁寧な回答ありがとうございました。
またなにかありましたらご協力のほど、よろしくお願いします。



おにたま(管理人)

リンク

2014/7/31(Thu) 22:19:12|NO.63248

HSP3Dishのご使用ありがとうございます。
古いandroid端末については、メモリ容量やバージョンなどの違いにより
正しく動作しない可能性もあります。
HSP3Dishの最低動作バージョン(2.3.3)以上で、HSP3Dishのサンプル(block3)なども
動作しない場合は、またお知らせください。

>kanahironさん

現在はデフォルトのAPI Levelが17になっていますが、
最低動作バージョンは、別途AndroidManifest.xml内で指定できます。

<uses-sdk android:minSdkVersion="10" />

現在は、API10(2.3.3)が指定されているはずです。



ONION software Copyright 1997-2021(c) All rights reserved.