HSPポータル
サイトマップ お問い合わせ


HSPTV!掲示板


未解決 解決 停止 削除要請

2017
0123
てんNDKビルドの失敗について2解決


てん

リンク

2017/1/23(Mon) 15:13:39|NO.78011

いつもお世話になります。

未熟ながら、色々なサイト様を参考にして、
ようやくdishのビルド環境を整えたのですが、
やはり、NDKビルド失敗しました。

原因の特定にお力添え頂けないでしょうか。

ソースはblock3を使用しました。
以下エラー内容です。

Android NDK: WARNING:jni/Android.mk:block3: non-system libraries in linker flags: -lobaqlib
Android NDK: This is likely to result in incorrect builds. Try using LOCAL_STATIC_LIBRARIES
Android NDK: or LOCAL_SHARED_LIBRARIES instead to list the library dependencies of the
Android NDK: current module
[armeabi-v7a] "Compile++ thumb": "block3 <= hsp3r.cpp"
process_begin: CreateProcess(NULL, G:/android/android-ndk-r13b-windows-x86/build//../toolchains/llvm/prebuilt/windows-x86_64/bin/clang++.exe -MMD -MP -MF ./obj/local/armeabi-v7a/objs/block3/hsp3embed/hsp3r.o.d -gcc-toolchain G:/android/android-ndk-r13b-windows-x86/build//../toolchains/arm-linux-androideabi-4.9/prebuilt/windows-x86_64 -fpic -ffunction-sections -funwind-tables -fstack-protector-strong -Wno-invalid-command-line-argument -Wno-unused-command-line-argument -no-canonical-prefixes -fno-integrated-as -g -target armv7-none-linux-androideabi -march=armv7-a -mfloat-abi=softfp -mfpu=vfpv3-d16 -fno-exceptions -fno-rtti -mthumb -Os -DNDEBUG -I../hsplib35b4 -IG:/android/android-ndk-r13b-windows-x86/build//../sources/cxx-stl/gnu-libstdc++/4.9/include -IG:/android/android-ndk-r13b-windows-x86/build//../sources/cxx-stl/gnu-libstdc++/4.9/libs/armeabi-v7a/include -IG:/android/android-ndk-r13b-windows-x86/build//../sources/cxx-stl/gnu-libstdc++/4.9/include/backward -Ijni -DANDROID -D__ANDROID__ -Wno-psabi -DHSPNDK
-DHSPEMBED -DHSPDISH -Wa,--noexecstack -Wformat -Werror=format-security -fexceptions -isystem G:/android/android-ndk-r13b-windows-x86/build//../platforms/android-9/arch-arm/usr/include -c jni/hsp3embed/hsp3r.cpp -o ./obj/local/armeabi-v7a/objs/block3/hsp3embed/hsp3r.o, ...) failed.
make (e=2): 指定されたファイルが見つかりません。

make: *** [obj/local/armeabi-v7a/objs/block3/hsp3embed/hsp3r.o] Error 2

-------------------------------
オプション設定です。
なるべく最新のものを選んだのですがこれがダメでしょうか?
(SDKはAndroid studio経由で10/17/21を入れたつもり…)

G:\android\jdk1.8.0_121
G:\android\sdk
G:\android\android-ndk-r13b-windows-x86
G:\android\apache-ant-1.10.0-bin
G:\android

宜しくお願い致しますm(_ _)m



この記事に返信する


てん

リンク

2017/1/24(Tue) 06:01:01|NO.78033

いつもお世話になります。

ndk-r9cでビルドできましたのでご連絡致します。
最終的には以下の環境ですm(__)m。

G:\android\jdk1.8.0_121
G:\android\sdk (Android studio経由)
G:\G:\android\android-ndk-r9c-windows-x86
G:\android\apache-ant-1.10.0-bin
G:\android



窓月らら

リンク

2017/1/26(Thu) 03:38:37|NO.78065

r9cで問題ないと思いますが、当方のテストでは
android-ndk-r10eまでは通ることを確認しています。
ご参考までに。



ONION software Copyright 1997-2021(c) All rights reserved.