HSPポータル
サイトマップ お問い合わせ


HSPTV!掲示板


未解決 解決 停止 削除要請

2013
1029
新入りHSP DirectSound Extension 実行ファイルにした際に音が鳴らない8解決


新入り

リンク

2013/10/29(Tue) 20:56:24|NO.57889

題名どおりです。
asもhpiも実行ファイルと同じフォルダにあります。
エディタから実行すれば問題なく鳴ります。

使用している命令は

ds_init
ds_load
ds_dup
ds_play
ds_stat

のみです。
何か「これはやった?」などあれば教えてください。



この記事に返信する


とおりすがり

リンク

2013/10/29(Tue) 22:23:09|NO.57893

初心者が「音が鳴らない」という場合、最初に疑うのは「音声/音楽ファイルのパス指定が間違っていないか」ですね。
必要な音声?音楽?ファイルは、実行ファイルと同じフォルダにありますか?



新入り

リンク

2013/10/29(Tue) 22:35:00|NO.57895

>とおりすがりさん
ご回答ありがとうございます。
残念ながら、ファイルは同じフォルダにありますし、パスも間違っていません。。。



ZAP

リンク

2013/10/30(Wed) 00:32:47|NO.57897

「dsoundex.hpi」を実行ファイルと同じ場所に置いていないとか?



ZAP

リンク

2013/10/30(Wed) 00:34:58|NO.57898

ああ、hpiも置いてるんですね。

実行ファイルを置いているファイルのパス名が長すぎるとか?
「D:\hsp」みたいな短いパス名で試してみては?



check

リンク

2013/10/30(Wed) 00:36:13|NO.57899

ファイル名はどのように指定している?
また、#pack等を使って内部に埋め込んでいたりしないか?



新入り

リンク

2013/10/30(Wed) 02:42:42|NO.57900

>checkさん
Wow!
パックとはasとかhpiのことかと思ったのですが、
試しに音楽ファイルのepackを消してみたら鳴りました!
これってパックしてはいけなかったんですね・・・。

解決しました、皆様ありがとうございます!



新入り

リンク

2013/10/30(Wed) 02:53:45|NO.57901

んん?

すみません、ちょっと気になることが。

今2つのプログラムで試してみたのですが、
片方はパックをしていると実行ファイルにすると鳴らず、
片方はパックをしている状態で実行ファイルにしても鳴ります。

この違いはなんなんでしょうか?

パックは、鳴る方はwavが1つと、ttfが1つ。
鳴らない方はpngが1つ、wavが3つ、mp3が1つ、ttcが1つです。



とおりすがり

リンク

2013/10/31(Thu) 15:19:30|NO.57914

一度「解決」にチェックしてしまうと埋もれてしまいやすいので、
別個のスレッドを作成した方が解答がもらいやすいかもしれません。

で、この件はこのへんが参考になりますね。
http://www.geocities.co.jp/Playtown-Yoyo/6130/hsp/hsp-packfile.html
googleなんかで " HSP #pack ファイル " とでもして検索してみてください。
手掛かりを上手に探すスキルも、プログラミングには大事ですよ。



ONION software Copyright 1997-2021(c) All rights reserved.