HSPポータル
サイトマップ お問い合わせ


HSPTV!掲示板


未解決 解決 停止 削除要請

2013
0828
ごりら音が鳴らない11解決


ごりら

リンク

2013/8/28(Wed) 23:45:03|NO.56717

pre
mmload "oto/爆発.wav"

mmplay
/pre
で音楽流せないんですけどなぜでしょうか
環境
windows 8 64bit版



この記事に返信する


ごりら

リンク

2013/8/28(Wed) 23:45:47|NO.56718

まちがえた こっちなwww
mmload "oto/爆発.wav"

mmplay



ななっしー

リンク

2013/8/29(Thu) 03:37:02|NO.56719

とりあえずヘルプでmmplayの書式を確かめましょう



koya

リンク

2013/8/29(Thu) 13:11:12|NO.56720

これではどうでしょう
1 ファイル名を"bakuhatu.wav"に変更
2

mmload "oto/bakuhatu.wav" ,1 mmplay 1
それと
preは
<と>の間にpreで終わりが<と>の間に/preです。



ごりら

リンク

2013/8/30(Fri) 06:19:02|NO.56746

まだなりません
不思議です



ミント

リンク

2013/8/30(Fri) 06:48:19|NO.56747

実行するフォルダーの中に効果音のやつ入ってますでしょうか?

入ってない場合は入れれば音が鳴るはずです。
もしフォルダーの中にフォルダーがある場合は、
「mmload "フォルダー名\\音.wav",1」みたいに「\\」を入れてください。



kanahiron

リンク

2013/8/30(Fri) 09:00:12|NO.56748

前あった事例を話すと、
mp3のファイルを拡張子だけ変えてwavにして鳴らない!!ってありましたね



ごりら

リンク

2013/8/30(Fri) 22:03:14|NO.56764

うーん
やっぱり鳴りませんね
一応全体のコードを


*top
cls



objsize 200,28:pos 200,300
button goto "スタート",*kisi
button goto "説明書",*setu
stop


*kisi
cls

結果=0
pos 120,400
button goto "ボタン1",*main
pos 270,400
button goto "ボタン2",*main
pos 430,400
button goto "ボタン3",*main
stop
*main
randomize
結果=rnd(2)

if 結果=0 {#include "hsp3util.as"


dialog "セーフ"


}

if 結果=1 {cls
cls 4
pos 130,100

picload "ga/爆発.png",1

mmload "oto/爆発.wav",1
mmplay
wait 500
goto*mouikai

}
stop
*mouikai
cls
pos 250,200
button goto "やり直す",*kisi
stop
*setu
cls
mes"ボタンをクリックして爆発を避けるだけ!!
button goto "戻る",*top



koya

リンク

2013/8/30(Fri) 22:15:42|NO.56766

mmplay のところで

mmplay 1
と1を追加してください。



ななっしー

リンク

2013/8/30(Fri) 22:23:06|NO.56767

鳴りませんってそりゃ指摘されたことを何一つ変えなかったら鳴らないでしょ・・・



ごりら

リンク

2013/8/30(Fri) 22:27:13|NO.56768

いや、一回変えましたが、ダメだったので元に戻しただけです



ごりら

リンク

2013/8/30(Fri) 22:29:10|NO.56769

koyaさん鳴りました
ありがとうございました



ONION software Copyright 1997-2018(c) All rights reserved.